6

It seems that the chess diagrams have stopped working throughout the site. For example, when viewing this question, now I see the following instead of the diagrams:

Screenshot

It seems that the issue affects all questions and answers with diagrams. I also tried on a different browser as well as on my phone, and I see the same issue.

Is this a known issue, and when will it be fixed?


If anyone is interested in looking at the code for the replayer, it is here: https://github.com/andrewphoy/chess-replayer

3

1 Answer 1

2

Almost 24 hours later, it appears to be working just fine. I suspect a blip somewhere in the system. However, until a higher-up pinpoints the true answer, we do not know.

Update: Per @hb20007's comment, I quote moderator #Benjamin Hodgson's comment on SE Meta page: "I think it was a Webpack bug. The chess code is set up to be loaded dynamically by the Webpack runtime system, but it had also been configured as an (unused) entry point in the Webpack config. As far as I know that's meant to be supported, and I couldn't reproduce it when I ran the build on my machine, but removing the entry point for the chess code does seem to have fixed the issue."

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .